Schematic symbol does not update after editing

PCB123 Schematic Questions and Discussion.

Moderator: Sunstone Moderators



Schematic symbol does not update after editing

Postby Sal Hernandez » Tue Sep 11, 2012 12:54 pm

This problem you are experiencing is a know issue that we hope to have resolved in a future release. The original version of the edited symbol is stored with the board file. If you close your design and start a new layout you could add the modified part and you would see the updated symbol. If you are too far along in the current schematic to start over, you can use the updated symbol by creating a new entry in the taxonomy with a unique name. Then remove the original symbol from your schematic and replace it with the updated version.

You could also get around this issue by modifying the schematic symbol then save it with a new name. Now you can pair the new symbol with the existing taxonomy entry. Then remove the original symbol from your schematic and replace it with the updated version.

This same behavior exists if you modify a symbols properties after it has already been added to your schematic. Changes to a parts properties while on the schematic will not show up in the BOM. You will need to use the method described above to update or create a new part in the taxonomy. Then remove the existing symbol on your schematic and replace it with the updated symbol to see your changes in the BOM.
Regards,

Sal Hernandez
Software Support Engineer I
Sunstone Circuits
13626 S. Freeman Road
Mulino, OR 97042
Phone: 503-829-9108 x226
Fax: 503-829-5482
User avatar
Sal Hernandez
 
Posts: 396
Joined: Wed Jul 06, 2011 12:00 am



Return to PCB123 Schematic

Who is online

Users browsing this forum: No registered users and 1 guest

cron